现在sae上的python版本是2.7的准确说应该是2.73,这个版本是python官方在2版本上支持的最新版。而我本机的版本是2.6,在使用上会发现一些本地可以正常运行,而sae上报错的情况,我怀疑是python版本的问题就更新了本地版本到2.73,升级中出现了PIL的错误,解决方法如下:

首先PIL是一个python的图片类库,使用方便,功能强大,但是从官方http://www.pythonware.com/products/pil/下载的2.7的最新版本在使用中报错The _imagingft C module is not installed,具体的说就是如果在程序中引用这几个包时import Image, ImageDraw, ImageFont,会报错,因为官方的包中没包含freetype的原因。

如果是linux系统,解决这个问题就要重新安装freetype,而window平台需要带上freetype重新编译PIL,我这儿有个编译好的包,可以安装即可解决这个问题。

PIL-1.1.7.win32-py2.7.rar:

http://pan.baidu.com/share/link?shareid=351830&uk=1896128931